Command Line Installation
Also available as:
loading table of contents...

Install the Storm Package

Prerequisite: Storm requires version 2.6 or higher of the default system Python interpreter.

  1. To install the Storm RPMs, run the following command on each client cluster node and gateway node:

    • For RHEL/CentOS/Oracle Linux:

      yum install storm

    • For SLES:

      zypper install storm

    • For Ubuntu and Debian:

      apt-get install storm


    Ubuntu and Debian users must manually create the /etc/storm/conf directory and the storm.yaml file that resides there.

  2. Run the following command to create the conf directory:

    sudo mkdir -p /etc/storm/conf

  3. Run the following command to create the storm.yaml file:

    sudo touch /etc/storm/conf/storm.yaml