Command Line Installation
Also available as:
PDF
loading table of contents...

Spark 2 Prerequisites

Before installing Spark 2, make sure your cluster meets the following prerequisites.

Table 20.1. Prerequisites for running Spark 2

PrerequisiteDescription
Cluster Stack Version
  • HDP 2.6.0 or later

(Optional) Ambari Version
  • Ambari 2.5.0 or later

Software dependencies

  • Spark 2 requires HDFS and YARN

  • PySpark and associated libraries require Python version 2.7 or later, or Python version 3.4 or later, installed on all nodes.


[Note]Note

When you install HDP 2.6.0, Spark 2 is installed.