Installation
Also available as:
PDF

System Requirements

To run HST, your system must meet requirements in the following areas:

Operating System Requirements

The following 64-bit operating systems are supported:

  • CentOS 6

  • CentOS 7 (it's recommended to have the net-tools package installed)

  • Debian 6

  • Debian 7

  • Red Hat Enterprise Linux (RHEL) 6

  • Red Hat Enterprise Linux (RHEL) 7 (it's recommended to have net-tools package installed)

  • SUSE Linux Enterprise Server (SLES) 11 SP3

  • SUSE Linux Enterprise Server (SLES) 12 SP1

  • Ubuntu 12.04

  • Ubuntu 14

  • Ubuntu 16

Software Requirements

You must install the following packages on each of the hosts in your cluster. These packages are used to gain a more complete diagnostic profile of the cluster.

  • wget

  • sysstat

  • dstat

  • lsof

  • net-tools

  • Python2, version 2.6 or later

JDK Requirements

The following Java runtime environments are supported:

  • Oracle JDK 1.8 64-bit

  • Oracle JDK 1.7 64-bit

  • OpenJDK 8 64-bit

  • OpenJDK 7 64-bit

Browser Requirements

The HST server runs a browser-based web application. To use this application, you must have a machine capable of running a graphical browser. Although you should update your browser to the latest stable version, the minimum required browser versions per operating system are as follows:

  • Windows (Vista, 7 or later)

    • Internet Explorer 11.0

    • Firefox 39

    • Google Chrome 43

  • Mac OS X (10.6 or later)

    • Safari 8

    • Firefox 39

    • Google Chrome 43

Ambari Requirements

You can integrate SmartSense with and deploy it through Apache Ambari. Ambari integration is certified with Apache Ambari 2.4.x or later.

Requirements for Activity Analysis

To use SmartSense Activity Analysis, you need the following component versions:

  • Apache Tez 0.5.2 or later

  • HDP 2.3 - 2.3.4.7+

  • HDP 2.4 - 2.4.x

  • HDP 2.5 - 2.5.x

  • HDP 2.6 - 2.6.x

[Note]Note

Ensure that your YARN App Timeline Server (ATS) is at least version 1.5. For information on how to upgrade to 1.5, refer to the Timeline Server 1.5 Overview documentation.