Installing Streams Messaging Manager
Also available as:
PDF

Install or Upgrade Ambari, HDF, and HDP

Get started with the SMM installation by preparing your target cluster. Your cluster must be managed by Ambari 2.7.0, and it can be an HDF 3.2 cluster, an HDP 3.0 cluster, or an HDP 3.0 cluster with HDF 3.2 services installed.

  1. Install or upgrade to Ambari 2.7.0.0.
  2. Install or upgrade your HDF 3.2.0 or HDP 3.0.0 cluster. You can also install HDF services on an HDP cluster.
    Review the Target cluster service requirements information to understand which services are required for SMM 1.0.0.