Hortonworks Data Platform for HDInsight
Also available as:
PDF

HDInsight Known Issues

Summary of known issues for this release specific to HDInsight. This release has the following known issues.

Bug ID Apache JIRA Apache component Summary
N/A N/A Kafka

Description of the problem or behavior

We strongly discourage downgrading from Kafka 2.1.0 to earlier versions. Though Ambari allows you to downgrade to earlier versions of Kafka after you upgrade to 2.1.0, consider the following before you do so.

Workaround

If you upgrade both the broker and consumer to 2.1.0, a downgrade might cause data loss.

If you upgrade the broker to 2.1.0 and the consumer remains at 2.0.0, then you can downgrade the broker to 2.0.0 without any issue.