Apache Solr Search Installation
Also available as:
PDF

Chapter 4. Upgrading HDP Search

This chapter describes prerequisites required to upgrade HDP Search 2.2.x to HDP Search 3.0.

Prerequisites

Before upgrading HDP Search, you must disable the yum repo priorities plug-in on all hosts that have the HDP Search Solr component installed, as follows:

# vi /etc/yum/pluginconf.d/priorities.conf 
[main]
enabled = 0

For detailed upgrade instructions, see Upgrading Solr.