Support Matrices
Also available as:
PDF

Chapter 1. Operating Systems Requirements

[Note]Note

The operating systems listed here do not cover HDP for IBM Power or IBM DSX. For requirements related to HDP for IBM Power, click here. For requirements related to HDP for IBM DSX, click here.

The following operating systems are supported for this release:

Table 1.1. Operating System Support

Operating SystemVersion
CentOS (64-bit)CentOS 7.0, 7.1, 7.2, 7.3, 7.4
CentOS 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8,6.9
DebianDebian 7
Oracle (64-bit)Oracle 7.0, 7.1, 7.2, 7.3, 7.4
Oracle 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8,6.9
Red Hat (64-bit)RHEL 7.0, 7.1, 7.2, 7.3, 7.4
RHEL 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
SUSE (64-bit)(SLES) Enterprise Linux 12, SP2
(SLES) Enterprise Linux 12, SP1
(SLES) Enterprise Linux 11, SP3
(SLES) Enterprise Linux 11, SP4
Ubuntu (64-bit)Ubuntu 16.04 (Xenial)
Ubuntu 14.04 (Trusty)

[Important]Important

For Ambari, the installer pulls many packages from the base OS repositories. If you do not have a complete set of base OS repositories available to all your machines at the time of installation you may run into issues.

If you encounter problems with base OS repositories being unavailable, please contact your system administrator to arrange for these additional repositories to be proxied or mirrored. For more information see Using a Local Repository.