Command Line Upgrade
Also available as:
PDF
loading table of contents...

Upgrade HDP 2.5 Components

[Important]Important

See the Release Notes for the HDP 2.6.2.0 repo information.

The upgrade process to HDP 2.6.0 involves the following steps.

Select your OS:

RHEL/CentOS/Oracle 6

  1. On all hosts, clean the yum repository.

    yum clean all

  2. Remove your old HDP 2.5 components. This command uninstalls the HDP 2.5 components. It leaves the user data, and metadata, but removes your configurations:

    yum erase "hadoop*" "webhcat*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue" "hue-common" "hue-shell" "knox*" "spark*" "slider*" "hdp_mon_nagios_addons "bigtop""
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    yum list installed | grep @HDP2.5

  4. Remove your old hdp.repo file:

    rm /etc/yum.repos.d/hdp.repo

  5. Install the HDP 2.6.0 repo:

    • Download the hdp.repo file:

      ?????wget -nv http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.6.0.0.0/hdp.repo -O /etc/yum.repos.d/hdp.repo
    • Confirm the HDP repository is configured.

      yum repolist

      You should see something like this. Verify that you have the HDP-2.6.0 directory:

      Loaded plugins: fastestmirror, security 
      Loading mirror speeds from cached hostfile
      * base: mirrors.cat.pdx.edu
      * extras: linux.mirrors.es.net
      * updates: mirrors.usc.edu 
      repo id repo namestatus
      HDP-2.6.0 Hortonworks Data Platform Version - HDP-2.6.0 
  6. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    yum install "hadoop" "hadoop-hdfs" "hadoop-libhdfs" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "hive-webhcat" "hive-hcatalog" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hue" "hive" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "slider" "hdp_mon_nagios_addons"
    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.

  7. Verify that the components were upgraded.

    yum list installed | grep HDP-<old.stack.version.number>

    No component file names should appear in the returned list.

RHEL/CentOS/Oracle 5 (Deprecated)

  1. On all hosts, clean the yum repository.

    yum clean all

  2. Remove your old HDP 2.5 components. This command uninstalls the HDP 2.5 components. It leaves the user data, and metadata, but removes your configurations:

    yum erase "hadoop*" "webhcat*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue" "hue-common" "hue-shell" "knox*" "spark*" "slider*" "hdp_mon_nagios_addons"
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    yum list installed | grep @HDP2.5

  4. Remove your old hdp.repo file:

    rm /etc/yum.repos.d/hdp.repo

  5. Install the HDP 2.6.0 repo:

    • Download the hdp.repo file:

      wget -nv http://public-repo-1.hortonworks.com/HDP/centos5/2.x/updates/2.6.0.0.0/hdp.repo -O /etc/yum.repos.d/hdp.repo
    • Confirm the HDP repository is configured.

      yum repolist

      You should see something like this. Verify that you have the HDP-2.6.0 directory:

      Loaded plugins: fastestmirror, security 
      Loading mirror speeds from cached hostfile
      * base: mirrors.cat.pdx.edu
      * extras: linux.mirrors.es.net
      * updates: mirrors.usc.edu 
      repo id repo namestatus
      HDP-2.6.0 Hortonworks Data Platform Version - HDP-2.6.0 
  6. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    yum install "hadoop" "hadoop-hdfs" "hadoop-libhdfs" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "webhcat" "hcatalog" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hive" "hue" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "slider*" "hdp_mon_nagios_addons"
    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.

  7. Verify that the components were upgraded.

    yum list installed | grep HDP-<old.stack.version.number>

    No component file names should appear in the returned list.

SLES 11 SP1

  1. On all hosts, clean the yum repository.

    zypper clean -all

  2. Remove your old HDP 2.5 components. This command uninstalls the HDP 2.5 components. It leaves the user data, and metadata, but removes your configurations:

    zypper rm "hadoop*" "webhcat*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue" "hue-common" "hue-shell" "knox*" "spark*" "slider*" "hdp_mon_nagios_addons"
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    yum list installed | grep @HDP2.5

  4. Remove your old hdp.repo file:

    rm /etc/zypp/repos.d/hdp.repo

  5. Download the HDP 2.6.0 hdp.repo file:

    wget -nv http://public-repo-1.hortonworks.com/HDP/sles11sp1/2.x/updates/2.6.0.0.0/hdp.repo -O /etc/zypp/repos.d/hdp.repo 
  6. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    zypper install "hadoop" "hadoop-hdfs" "hadoop-libhdfs" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "webhcat" "hcatalog" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hive" "hue" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "slider*" "hdp_mon_nagios_addons"

    zypper install webhcat-tar-hive webhcat-tar-pig

    zypper up -r HDP-2.6.0

    zypper install oozie-client

    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.

  7. Verify that the components were upgraded. For example, to verify hdfs, hive, and hcatalog:

    rpm -qa | grep hdfs, && rpm -qa | grep hive && rpm -qa | grep hcatalog

    No component files names should appear in the returned list.

SLES 11 SP3/SP4, SLES 12

  1. On all hosts, clean the zypper repository.

    zypper clean -all

  2. Remove your old HDP 2.5 components.

    zypper rm "hadoop*" "webhcat*" "hcatalog*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue" "hue-common" "hue-shell" "knox*" "ranger*" "spark*" "slider*" "hdp_mon_nagios_addons"
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    zypper search --installed-only --repo HDP-2.5.0.0

  4. Remove your old hdp.repo file:

    rm /etc/zypp/repos.d/hdp.repo

  5. Download the HDP 2.6.0 hdp.repo file:

    http://public-repo-1.hortonworks.com/HDP/suse11sp3/2.x/updates/2.6.0.0.0/hdp.repo -O /etc/zypp/repos.d/hdp.repo

  6. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    zypper install "hadoop" "hadoop-hdfs" "hadoop-libhdfs" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hue" "hive" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "spark-python" "hdp_mon_nagios_addons "slider*" "hive-webcat" "hive-hcatalog""

    zypper up -r HDP-2.6.0

    zypper install oozie-clientt

    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.

  7. Verify that the components were upgraded. For example, to verify hdfs, hive, and hcatalog:

    rpm -qa | grep hdfs, && rpm -qa | grep hive && rpm -qa | grep hcatalog

    No component files names should appear in the returned list.

Ubuntu 12

  1. On all hosts, clean the apt-get repository.

    apt-get clean -&-all

  2. Remove your old HDP 2.5 components. This command uninstalls the HDP 2.5 components. It leaves the user data, and metadata, but removes your configurations:

    apt-get remove "hadoop*" "webhcat*" "hcatalog*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez.*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue.*" "knox*" "spark*" "slider*" "hdp_mon_nagios_addons" --purge
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    yum list installed | grep @HDP2.5

  4. Remove your old hdp.repo file:

    rm /etc/apt/sources.list.d/hdp.list

  5. Download the HDP 2.6.0 hdp.repo file:

    wget http://public-repo-1.hortonworks.com/HDP/ubuntu12/2.x/updates/2.6.0.0.0/hdp.list - O /etc/apt/sources.list.d/hdp.list

  6. Run an update:

    apt-get update

  7. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    apt-get install "hadoop" "hadoop-hdfs" "libhdfs0" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "webhcat" "hcatalog" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hive" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "slider*" "hdp_mon_nagios_addons"
    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.

Debian

  1. On all hosts, clean the apt-get repository.

    apt-get clean -&-all

  2. Remove your old HDP 2.5 components. This command uninstalls the HDP 2.5 components. It leaves the user data, and metadata, but removes your configurations:

    apt-get remove "hadoop*" "webhcat*" "hcatalog*" "oozie*" "collectd*" "gccxml*" "pig*" "hdfs*" "sqoop*" "zookeeper*" "hbase*" "hive*" "tez*" "storm*" "falcon*" "flume*" "phoenix*" "accumulo*" "mahout*" "hue*" "knox*" "spark*" "slider*" "hdp_mon_nagios_addons"
  3. Validate that all HDP 2.5 component binaries are uninstalled:

    yum list installed | grep @HDP2.5

  4. Remove your old hdp.repo file:

    rm /etc/apt/sources.list.d/hdp.list

  5. Download the HDP 2.6.0 hdp.repo file:

    wget -nv http://public-repo-1.hortonworks.com/HDP/debian<version>/2.x/updates/2.6.0.0.0/hdp.list - O /etc/apt/sources.list.d/hdp.list

  6. Run an update:

    apt-get update

  7. Install the HDP 2.6.0 versions of the components that you want to upgrade. For example, if you installed and want to upgrade all HDP 2.5 components:

    apt-get install "hadoop" "hadoop-hdfs" "libhdfs0" "hadoop-yarn" "hadoop-mapreduce" "hadoop-client" "openssl" "webhcat" "hcatalog" "oozie" "collectd" "gccxml" "pig" "sqoop" "zookeeper" "hbase" "hive" "tez" "storm" "falcon" "flume" "phoenix" "accumulo" "mahout" "knox" "spark" "slider*" "hdp_mon_nagios_addons"
    [Note]Note

    If you installed Apache Ranger, see Upgrade Ranger for more information on the upgrade path.