Apache Ambari Upgrade Best Practices
Also available as:

Verifying Versions

Validate that the OS, Java Development Kit, and the metastore versions are compliant with the version of HDP and Ambari to which you plan to upgrade; for example, Oracle Database 12c is supported with Ambari Confirm that your Ambari version is compatiable with your current version of HDP. See Determine Stack Compatibility in the Automated Install with Ambari Guide.