Security
Also available as:
PDF
loading table of contents...

Supported Hadoop Services

Apache Knox Gateway supports the following Hadoop services versions in both Kerberized and Non-Kerberized clusters:

Table 2.20. Supported Hadoop Services

ServiceVersion
YARN2.6.0+
WebHDFS2.6.0+
WebHCat/Templeton0.13.0+
Oozie4.1.0+
HBase/Stargate0.98.4+
Hive (via WebHCat)0.14.0+
Hive (via JDBC)0.14.0+
Ambari2.4.0+
Ranger0.6.0+


Table 2.21. Supported Hadoop UIs

Service
Ambari UI
Ranger Admin Console


[Note]Note

UIs in the Apache Knox project that are not listed above are considered Community Features.

Community Features are developed and tested by the Apache Knox community but are not officially supported by Hortonworks. These features are excluded for a variety of reasons, including insufficient reliability or incomplete test case coverage, declaration of non-production readiness by the community at large, and feature deviation from Hortonworks best practices. Do not use these features in your production environments.​