Also available as:
loading table of contents...
Library Support for AES-NI optimization

You will need a version of the library that supports hardware acceleration, such as OpenSSL 1.0.1e. (Many OS versions have an older version of the library that does not support AES-NI.)

A version of the library with AES-NI support must be installed on HDFS cluster nodes and MapReduce client hosts -- that is, any host from which you issue HDFS or MapReduce requests. The following instructions describe how to install and configure the library.

RHEL/CentOS 6.5 or later

On HDP cluster nodes, the installed version of supports AES-NI, but you will need to make sure that the symbolic link exists:

$ sudo ln -s /usr/lib64/ /usr/lib64/

On MapReduce client hosts, install the openssl-devel package:

$ sudo yum install openssl-devel