Support Matrices
Also available as:
PDF

Chapter 1. HDF 3.1.0: Support

The matrices in this chapter outline what is supported for HDF 3.1.0.

Supported Operating Systems

The following table outlines the supported operating systems for HDF 3.1.0.

Operating SystemVersion
CentOS (64-bit)CentOS 7.0, 7.1, 7.2, 7.3, 7.4
CentOS 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
DebianDebian 7
Oracle (64-bit)Oracle 7.0, 7.1, 7.2, 7.3, 7.4
Oracle 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8,6.9
Red Hat (64-bit)RHEL 7.0, 7.1, 7.2, 7.3, 7.4
RHEL 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
SUSE (64-bit)(SLES) Enterprise Linux 12, SP2
(SLES) Enterprise Linux 12, SP1
(SLES) Enterprise Linux 11, SP3
(SLES) Enterprise Linux 11, SP4
Ubuntu (64-bit)Ubuntu 16.04 (Xenial)
Ubuntu 14.04 (Trusty)

Supported Upgrade Paths

[Important]Important

Depending on the your installation scenario and the HDF servies you have previously installed, your upgrade path will be different. It is important that you review your options here and in the Apache Ambari Managed HDF Upgrade documentation before you begin.

ComponentVersionHDFHDF on HDP
NiFi1.5.0YesYes
NiFi Registry0.1.0N/A (Initial installation)N/A (Initial installation)
Storm1.1.1YesNo
Kafka1.0.0YesNo
SAM0.6.0YesNo
Schema Registry0.4.0YesNo
Logsearch0.5.0YesYes
Ranger0.7.0YesYes
Ambari Infra0.1.0YesYes
Ambari Metrics0.1.0YesYes
ZooKeeper3.4.6YesYes
[Important]Important

You cannot install SAM and Schema Registry for HDF 3.1 on an HDP cluster, and you cannot upgrade these services from a previous HDP cluster. For information about using an upgraded version of SAM and Schema Registry with HDF 3.1, see the Apache Ambari Managed HDF Upgrade.

[Important]Important

You cannot upgrade your HDF Storm and Kafka versions if they exist on an HDP cluster.

More Information

Apache Ambari Managed HDF Upgrade

Supported Browsers

  • Mozilla Firefox: current & current - 1

  • Google Chrome: current & current - 1

  • Microsoft Edge

  • Safari 8

Compatibility with HDP Component Version

Depending on how you have deployed HDF, you should be aware of several HDP component version compatibility requirements.

If you are running HDP, ensure that you have reviewed the HDP Support Matrices.

More Information

HDP Support Matrices

HDF 3.1.0 Only Deployment

When you have NiFi processors talking to HDP services, you can use HDP cluster versions 2.5.x and 2.6.x. HDP services that communicate with NiFi processors include:

  • HDFS

  • Hive

  • HBase

  • Kafka

When you have the NiFi Atlas reporting task communicating with Atlas on an HDP cluster, you must be running HDP 2.6.0 and later.

HDF Services on an HDP Cluster

When you install HDF 3.1 Servies (NiFi and NiFi Registry) on an HDP cluster, you must install them on an HDP 2.6.4 cluster.

Supported Ambari Versions

[Important]Important

HDF 3.1.0 runs with Ambari 2.6.0 and 2.6.1. It does not run with earlier versions of Ambari.

Ambari*

HDF 3.0.2

HDF 3.1.0

2.6.1

2.6.0

2.5.x

  

Ensure that you have reviewed the Ambari Support Matrices.

More Information

Ambari Support Matrices

Supported JDKs

You must have one of the following JDKs installed on the system running HDF.

  • Open JDK8

  • Oracle JDK 8

If you a performing an installation using Ambari, Oracle JDK 8 is installed for you.

Supported Databases

Ambari requires a relational database to store information about the cluster configuration and topology. A number of additional components also require an existing relational database.

[Warning]Warning

You must install Postgres 9.5 or later for SAM and Schema Registry. Ambari does not install Postgres 9.5, so you must perform a manual Postgres installation.

ComponentDatabaseDescription
Ambari
  • PostgreSQL 9.1.13+,9.3, 9.4

  • MariaDB 10

  • MySQL 5.6

  • Oracle 11gr2

  • Oracle 12

By default, Ambari installs an instance of PostgreSQL on the Ambari Server host. Optionally, you can use an existing instance of PostgreSQL, MySQL or Oracle.

Ranger
  • PostgreSQL 9.1.13+, 9.3, 9.4***

  • MariaDB 10*

  • MySQL 5.6****

  • Oracle 11gr2

  • Oracle 12c**

You must have an existing instance of PostgreSQL , MySQL or Oracle available for Ranger.
Streaming Analytics Manager
  • Postgres 9.5 or later

  • MySQL 5.5 or later

  • Oracle 12 and 11g Release 2

  • MariaDB 10

 
Schema Registry
  • Postgres 9.5 or later

  • MySQL 5.5 or later

  • Oracle 12 and 11g Release 2

  • MariaDB 10