DLM Installation and Upgrade
Also available as:
PDF

Version recommendation for DLM and HDP

You must ensure that you are using versions of DLM App, DLM Engine, HDP, and Ambari that are supported together.

It is strongly recommended that you install the latest version of DLM, to take advantage of the latest functionality and the stability updates.

DataPlane Platform and DLM App should be the latest version. DLM capabilities supported here are the features of the minimum DLM Engine version.

DLM Engine should be on the latest version available for the HDP version that you have installed in your environment. You can upgrade HDP to the version that the latest DLM Engine version requires to perform in a seamless manner.

DLM 1.3.0 version is compatible with HDP 2.6.5.1050 and HDP 3.1 releases. HDP 2.6.5.1050 release has fixes in different components of HDP like Hive, Ranger, and Atlas to enable the DLM functionality. If you are performing replication using Google Cloud Storage, you must perform a full cluster upgrade to HDP 2.6.5.1050 release. If you are not using Google Cloud Storage, use Ambari patch upgrade process, which will upgrade just the required components of HDP stack, so that other HDP components are not affected.

Note
Note
DLM 1.3.0 only supports on-premise to on-premise replication with HDP 2.6.5.1050 as source and HDP 3.1 as destination.

If you are on an earlier version of HDP, use a standard full upgrade to HDP 2.6.5.1050. Please reach out to Hortonworks support team to get HDP 2.6.5.1050.