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Ambari Configuring Specific Views

Configuring Specific Views

Ambari configures and deploys most views automatically, for each service added to a cluster.

Depending on your environment, each view (and associated service) may require some additional configuration or
troubleshooting.

Configuring Capacity Scheduler View

If you have deployed your cluster manually, or if you need to re-configure the Ambari-created YARN Queue
Manager View, you can use the following topics to create and configure a view instance.

Create a Capacity Scheduler View instance
When you deploy a cluster using Ambari, a Capacity Scheduler View instance is automatically created.

About this task
If you do not need to reconfigure the Ambari-created cluster, proceed to use the YARN Queue Manager View. If
you have deployed your cluster manually, or if you need to re-configure the Ambari-created YARN Queue Manager
View, you can use the following topics to create and configure a view instance. To set up a Capacity Scheduler /
YARN Queue Manager view instance:

Before you begin
Capacity Scheduler View requires that the cluster is managed by Ambari. Capacity Scheduler View utilizes the
Ambari Server API.

Procedure

1. In the Ambari Web user menu, click admin > Manage Ambari.

2. On the Ambari Admin page, click Views.
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3. On the Views page, click CAPACITY-SCHEDULER, then click Create Instance.

4. In the Details box on the Create Instance page, type an instance name, display name, and a description for the
view.

The instance name cannot contain spaces or special characters.

5. In the Cluster Configuration box on the Create Instance page, configure the view to communicate with the
HDP cluster.

• For HDP clusters that are local (managed by the local Ambari Server), click the Local Ambari Managed Cluster
option, then click the local cluster name.

• To configure the view to work with HDP clusters that are remote (not part of this Ambari Server instance),
click the Custom option, then enter the remote Ambari cluster API URL and the Ambari cluster user name and
password.

6. Click Save at the bottom of the Create Instance page.
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Results
A Capacity Scheduler View instance is created, and the configuration page for the instance

appears.

What to do next
Set Capacity Scheduler (YARN Queue Manager) View user permissions.

Set YARN Queue Manager View user permissions
To add users and groups to a YARN Queue Manager view instance:

Procedure

1. On the Capacity Scheduler view instance configuration page, in Permissions, click Add User.
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2. In Use, enter user names, then click the blue check mark to add the users. You can use the same method to add
groups in Add Group.
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3. After you have finished adding users and groups, click Go to instance at the top of the page to open the YARN
Queue Manager view instance.
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The Capacity Scheduler view instance page

appears.

Configure your cluster for Files View

For Files View to access HDFS, the Ambari Server daemon hosting the view needs to act as the proxy user for HDFS.

About this task
This allows Ambari to submit requests to HDFS on behalf of Files View users.

If you are running views in an operational Ambari server (one that is operating the cluster) Ambari does this setup
by default. You should verify that the setup described in the following subsections has been completed. If you are
running views on a standalone server, you must setup proxy user settings manually.

To set up an HDFS proxy user for the Ambari Server daemon account, you need to configure the proxy user in the
HDFS configuration. This configuration is determined by the account name the ambari-server daemon is running as.
For example, if your ambari-server is running as root, you set up an HDFS proxy user for root with the following:

Procedure

1. In Ambari Web, browse to Services > HDFS > Configs.

2. On the Advanced tab, browse to the Custom core-site section.

3. Click Add Property…

4. Enter the following custom properties:

hadoop.proxyuser.root.groups="users"
hadoop.proxyuser.root.hosts=ambari-
server.hostname

Notice the ambari-server daemon account name
root is part of the property name. Be sure to modify
this property name for the account name you are
running the ambari-server as. For example, if you were
running ambari-server daemon under the account name
ambariusr, you would use the following properties
instead:
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hadoop.proxyuser.ambariusr.groups="users"
hadoop.proxyuser.ambariusr.hosts=ambari-
server.hostname

Similarly, if you have configured Ambari Server for
Kerberos, be sure to modify this property name for
the primary Kerberos principal user. For example, if
ambari-server is setup for Kerberos using principal
ambari-server@EXAMPLE.COM, you would use the
following properties instead:

hadoop.proxyuser.ambari-server.groups="users"
hadoop.proxyuser.ambari-server.hosts=ambari-
server.hostname

5. Save the configuration change.

What to do next
Restart the required components as prompted by Ambari.

Create and configure a Files View instance

Ambari creates and configures a Files View instance automatically.

About this task
Only use this information if your Files View instance does not appear as expected.

Procedure

1. Browse to the Ambari Admin page.

2. Click Views > Files View > Create Instance.

3. In Details, enter the following values for View instance properties:

Table 1: Files View Properties

Property Description Value

Instance Name This is the Files view instance name. This value should be unique for all
Files view instances you create. This value cannot contain spaces and is
required.

FILES_1

Display Name This is the name of the view link displayed to the user in Ambari Web. MyFiles

Description This is the description of the view displayed to the user in Ambari Web. Browse HDFS files and
directories.

Visible This checkbox determines whether the view is displayed to users in
Ambari Web.

Visible or Not Visible

4. Complete the Files View configuration, using the following guidance:

Information that you provide in Settings and Cluster Configuration depends on your environment; specifically,
whether:

• your cluster is Kerberos-enabled or not
• NameNode HA is enabled or not
• your Files View instance resides in an operational or a standalone Ambari server
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Table 2: Files View Configuration

Kerberos
Enabled

NameNode HA
Enabled

Operational Ambari Server Standalone Ambari Server

No No

No Yes

Settings: defaults

Cluster Configuration: Local

Settings: defaults

Cluster Configuration: Custom

Yes No Settings: Kerberos

Cluster Configuration: Custom

Yes Yes Settings: Kerberos

Cluster Configuration: Custom

What to do next
Enable the Local Ambari Managed Cluster Configuration option in the Ambari Admin page, only if you are
managing a cluster in an Operational Ambari Server.

Set up Kerberos for Files View

Reguirements for operating Files View in a Kerberized cluster.

Before you begin
Set up Kerberos for Ambari by configuring the Ambari Server daemon with a Kerberos principal and keytab.

Procedure

• In Files View > Settings, enter the following properties:

Table 3: Kerberos Settings for Files View

Property Description Example Value

WebHDFS Username This is the username the view will access HDFS
as. Leave this default value intact to represent the
authenticated view user.

${username}

WebHDFS Authorization This is the semicolon-separated authentication
configuration for WebHDFS access.

auth=KERBEROS;proxyuser=ambari-server

**This property is only needed if the view
is Custom Configured or Ambari Server is
Kerberized before 2.4.0.

With a Kerberos setup, the proxy user setting should be the primary value of the Kerberos principal for Ambari
Server. For example, if you configured Ambari Server for Kerberos principal ambari-server@EXAMPLE.COM,
this value would be ambari-server.

Configure local option for Files View

When you configure Files View using the Local option, Files View communicates with HDFS based on the
fs.defaultFS property.
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About this task
The Local Ambari Managed Cluster Configuration option is enabled on the Ambari Admin page if you are
managing a cluster with Ambari. Ambari will automatically configure Files View based on how the cluster is
configured.

Procedure

• When Local Ambari Managed Cluster Configuration is enabled, you can choose Local Ambari Managed
Cluster Configuration.
When you configure Files View using the Local option, Files View communicates with HDFS based on the
fs.defaultFS property.

• For example: hdfs://namenode:8020.

Files View also determines whether NameNode HA is configured and adjusts accordingly.

Configure custom option for Files View

There are certain properties that you must configure for Custom Files View.

Table 4: Properties Required for Custom Files View Option

Required Properties Description Example Value

WebHDFS FileSystem URI The WebHDFS FileSystem URI in the format
webhdfs://[HOST]:[HTTP_PORT]

webhdfs://namenode:50070

These properties are required if your cluster is configured for NameNode HA.

Table 5: Properties Required for Custom Files View with NN HA

Property Description Example Value

Logical name of the NameNode
cluster

Comma-separated list of nameservices. hdfs-site/dfs.nameservices

For example:

nameservice

List of NameNodes Comma-separated list of NameNodes for a given
nameservice.

hdfs-site/dfs.ha.namenodes

For example:

namenode1,namenode2

First NameNode RPC Address RPC address for first name node. hdfs-site/dfs.namenode.rpc-address.[nameservice].
[namenode1]

Second NameNode RPC Address RPC address for second NameNode. hdfs-site/dfs.namenode.rpc-address.[nameservice].
[namenode2]

First NameNode HTTP
(WebHDFS) Address

WebHDFS address for first NameNode. hdfs-site/dfs.namenode.http-address.[nameservice].
[namenode1]

Second NameNode HTTP
(WebHDFS) Address

WebHDFS address for second NameNode. hdfs-site/dfs.namenode.http-address.[nameservice].
[namenode2]

Failover Proxy Provider The Java class that HDFS clients use to contact the
Active NameNode.

hdfs-site/dfs.client.failover.proxy.provider.
[nameservice]
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Configuring Pig View

To configure Pig View

Perform the following tasks:

Configure your cluster for Pig View
For Pig View to access HDFS, the Ambari Server daemon hosting the view must act as the proxy user for HDFS. The
Ambari Pig View is deprecated in HDP 3.0 and later. Ambari does not enable Pig View. To enable Pig View in HDP
3.0 and later, you need to contact Hortonworks support for instructions that include how to install WebHCat using an
Ambari management pack.

Ambari submits requests to HDFS on behalf of the users using the Pig View. This is critical since Pig View will store
metadata about the user Pig scripts. This also means users that will access Pig View must have a user directory setup
in HDFS. In addition, Pig View uses WebHCat to submit Pig scripts so the View needs a proxy user for WebHCat.

Set up HDFS proxy user for Pig View
To set up an HDFS proxy user for the Ambari Server daemon account, you must configure the proxy user in the
HDFS configuration.

About this task
This configuration is determined by the account name the ambari-server daemon is running as. For example, if your
ambari-server is running as root, you set up an HDFS proxy user for root .

Procedure

1. In Ambari Web, browse to Services > HDFS > Configs.

2. On the Advanced tab, navigate to the Custom core-site section.

3. Click Add Property… to add the following custom properties:

hadoop.proxyuser.root.groups="users"
hadoop.proxyuser.root.hosts=ambari-server.hostname

Notice the ambari-server daemon account name root is part of the property name. Be sure to modify this property
name for the account name you are running the ambari-server as. For example, if you were running ambari-server
daemon under the account name ambariusr, you would use the following properties instead:

hadoop.proxyuser.ambariusr.groups="users"
hadoop.proxyuser.ambariusr.hosts=ambari-server.hostname

Similarly, if you have configured Ambari Server for Kerberos, be sure to modify this property name for the
primary Kerberos principal user. For example, if ambari-server is set up for Kerberos using principal ambari-
server@EXAMPLE.COM, you would use the following properties instead:

hadoop.proxyuser.ambari-server.groups="users"
hadoop.proxyuser.ambari-server.hosts=ambari-server.hostname

4. Save the configuration change.

What to do next
Restart the required components as prompted by Ambari.
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Set up WebHCat proxy user for Pig View
You must set up an HDFS proxy user for WebHCat and a WebHCat proxy user for the Ambari Server daemon
account.

About this task
To set up the HDFS proxy user for WebHCat :

Procedure

1. In Ambari Web, browse to Services > HDFS > Configs.

2. On the Advanced tab, navigate to the Custom core-site section.

3. Click Add Property… to add the following custom properties:

hadoop.proxyuser.hcat.groups=*
hadoop.proxyuser.hcat.hosts=*

4. Save the configuration change and restart the required components as prompted by Ambari.

What to do next
set up a WebHCat proxy user for the Ambari Server daemon account.

Set up WebHCat proxy user for the Ambari Server daemon account
To setup a WebHCat proxy user for the Ambari Server daemon account, you need to configure the proxy user in the
WebHCat configuration.

About this task
This configuration is determined by the account name the ambari -server daemon is running as. For example, if your
ambari -server is running as root, you set up an WebHCat proxy user for root.

Procedure

1. In Ambari Web, browse to Services  > Hive > Configs.

2. On the Advanced tab, navigate to the Custom webhcat-site section.

3. Click Add Property… to add the following custom properties:

4. Save the configuration change and restart the required components as indicated by Ambari.

webhcat.proxyuser.root.groups=*
webhcat.proxyuser.root.hosts=*

Notice the ambari-server daemon account name root is part of the property name. Be sure to modify this property
name for the account name you are running the ambari-server as. For example, if you were running ambari-server
daemon under an account name of ambariusr, you would use the following properties instead:

webhcat.proxyuser.ambariusr.groups=*
webhcat.proxyuser.ambariusr.hosts=*

Similarly, if you have configured Ambari Server for Kerberos, be sure to modify this property name for the
primary Kerberos principal user. For example, if ambari-server is setup for Kerberos using principal ambari-
server@EXAMPLE.COM, you would use the following properties instead:

webhcat.proxyuser.ambari-server.groups=*
webhcat.proxyuser.ambari-server.hosts=*
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Set up HDFS user directory
Is this task necessary for Pig View ??? seems Hive-specific

About this task
The Hive View stores user metadata in HDFS. By default, the location in HDFS for this metadata is /user/
$[USER_NAME] where $[USER_NAME] is the user name of the currently logged in user that is accessing the Hive
View.

Before you begin
Since many users leverage the default Ambari admin user for getting started with Ambari, the /user/admin folder must
be created in HDFS. Therefore, be sure to create the admin user directory in HDFS using these instructions before
using the view.

Procedure

1. Connect to a host in the cluster that includes the HDFS client.

2. Switch to the hdfs system account user.
su - hdfs

3. Using the HDFS client, make an HDFS directory for the user.
For example, if your username is admin, you would create the following directory:hadoop fs -mkdir /user/admin

4. Set the ownership on the newly created directory.
For example, if your username is admin, you would make that user the directory owner. hadoop fs -chown
admin:hadoop /user/admin

Create and configure a Pig View instance
To create a Pig View Instance:

Procedure

1. Browse to the Ambari Admin interface.

2. Click Views, expand the Pig View, and click Create Instance.

3. On the Create Instance page, select Version.

If multiple Pig View jars are present, choose one.

4. Enter the Details and Settings.
The Instance Name appears in the URI, the Display Name appears in the Views drop-down list, and the
Description helps multiple users identify the view:
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5. Scroll down, and enter the Cluster Configuration information.

which tells the Pig View how to access resources in the cluster.

For a cluster that is deployed and managed by Ambari, select Local Ambari Managed Cluster:
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6. Click Save.

7. Give permissions to the appropriate users and groups.

What to do next
Click Go to instance at the top of the page open instance of Pig View that you created.

Get correct configuration values for Pig View in a manually-deployed cluster

About this task
If you have manually deployed your cluster, you must enter cluster configuration values in the Pig View > Create
Instance page. The following table explains where you can find cluster configuration settings in Ambari.

Scripts HDFS Directory* /user/${username}/pig/scripts

Jobs HDFS Directory* /user/${username}/pig/jobs

WebHDFS FileSystem URI* Click HDFS > Configs > Advanced hdfs-site  >
dfs.namenode.http-address. When you enter the value
in the view definition, pre-pend webhdfs:// to the value
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you find in the advanced HDFS configuration settings.
For example, webhdfs://c6401.ambari.apache.org:50070

WebHCat Hostname* Click Hive > Configs > Advanced > WebHCat
Server > WebHCat Server host to view the hostname.
For example, c6402.ambari.apache.org

WebHCat Port* Click Hive > Configs > Advanced > Advanced
webhcat-site > templeton.port to view the port number.
For example, 50111

For NameNode High Availability, the following values must be entered for primary and secondary NameNodes:

First NameNode RPC Address or Second NameNode
RPC Address

Select the primary or secondary NameNode to view
settings from that host in the cluster. When you enter
the value in the view definition, pre-pend http:// to the
value you find in the advanced hdfs-site  settings. For
example, http://c6401.ambari.apache.org:8020

First NameNode HTTP (WebHDFS) Address or
Second NameNode HTTP (WebHDFS) Address

Click  HDFS > Configs > Advanced > Advanced hdfs-
site > dfs.namenode.http-address. When you enter
the value in the view definition, pre-pend http:// to the
value you find in the advanced hdfs-site  settings. For
example, http://c6401.ambari.apache.org:50070

To get First NameNode RPC Address values:

Procedure

1. In Ambari Web, browse to the HDFS Summary page. Click NameNode (primary) or  SNameNode (secondary)
to view the host page:
HDFS Service Page in Ambari:

2. On the host page, click Configs > Advanced.

3. Enter rpc in the Filter search well at the top right corner of the page or navigate to the Advanced hdfs-site settings
to find the dfs.namenode.rpc-address value that you can enter into the Pig View definition.
Here is an example of using Filter to search settings in Advanced hdfs-site.
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Set up user permissions for Pig View

Before you begin
Save the Pig View instance definition

Procedure

1. Grant view permissions for all Pig View users.

2. On the Pig View instance configuration page, in Permissions, click Add User.
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3. In Use, enter user names, then click the blue check mark to add the users. You can use the same method to add
groups in Add Group.

4. After you have finished adding users and groups, click Go to instance at the top of the page to open the Pig View
instance.

Set up Kerberos for Pig View

Before you begin
Set up basic Kerberos for the Ambari views server.

Procedure

• Manually set the following Pig View property:

WebHDFS Authentication auth=KERBEROS;proxyuser=[AMBARI_PRINCIPAL_NAME]
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This property is only needed if the view is Custom Configured or Ambari Server is Kerberized before 2.4.0.

Configuring SmartSense View

When you deploy a cluster with Ambari, a SmartSense View instance is automatically created as long as an Ambari
Agent is deployed on the host running the Ambari Server.

If necessary, review and complete the following procedures:

Configure your cluster for SmartSense View
If an Ambari Agent is not installed on the Ambari Server host, the view will not be automatically created, and you
will have to add a SmartSense instance manually.

Before accessing SmartSense View, you should enter your SmartSense user ID, account name (both are available
in the Hortonworks support portal in the Tools tab), and email address in the SmartSense service configuration
properties.

Create a SmartSense View instance
To create a SmartSense view instance manually:

Procedure

1. Browse to the Ambari Admin user interface.

2. Click Views > HORTONWORKS_SMARTSENSE, expand the menu, and click Create Instance.
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3. On the Create Instance page, select the Version.

If multiple SmartSense View jars exist, choose one.

4. Enter the following view instance details.

Instance Name This is the SmartSense view instance name. This value
should be unique for all SmartSense view instances
you create. This value cannot contain spaces and is
required.

Display Name This is the name of the view link displayed to the user
in Ambari Web.
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Description This is the description of the view displayed to the user
in Ambari Web.

5. Enter the following view instance settings:

hst.server.url This is the HST server URL. This should be http://
<HST_host>:9000/

hst.server.username The default username is 'admin'.

hst.server.password Unless changed after installation, the default password
is 'admin'.

6. Click Save.

Configure Workflow Manager View

Before you can access Workflow Manager, you must complete several configuration tasks.

See the following content:

Configure your cluster for Workflow Manager View
For Workflow Manager View to access HDFS, the Ambari Server daemon hosting the view must act as the proxy
user for HDFS.

About this task
This allows Ambari to submit requests to HDFS on behalf of the Worklow Manager View users.

Before you begin

• Each Worklow Manager View user must have a user directory set up in HDFS.
• If the cluster is configured for Kerberos, ensure that Views is also set up for Kerberos.

Set up HDFS proxy user
To set up an HDFS proxy user for the Ambari Server daemon account, you must configure the proxy user in the
HDFS configuration.

About this task

Note:  If you previously set up the proxy user for another View, you can skip this task.

This configuration is determined by the account name the ambari-server daemon is running as. For example, if your
ambari-server is running as root, you set up an HDFS proxy user for root.

Procedure

1. In Ambari Web, browse to Services > HDFS > Configs.

2. On the Advanced tab, navigate to the Custom core-site section.

3. Click Add Property…, then add the following custom properties:

hadoop.proxyuser.root.groups="users"
hadoop.proxyuser.root.hosts=ambari-server.hostname
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Notice the ambari-server daemon account name root is part of the property name. Be sure to modify this property
name for the account name you are running the ambari-server as. For example, if you were running ambari-server
daemon under an account name of ambariusr, you would use the following properties instead.

hadoop.proxyuser.ambariusr.groups="users"
hadoop.proxyuser.ambariusr.hosts=ambari-server.hostname

Similarly, if you have configured Ambari Server for Kerberos, be sure to modify this property name for the
primary Kerberos principal user. For example, if ambari-server is setup for Kerberos using principal ambari-
server@EXAMPLE.COM, you would use the following properties instead:

hadoop.proxyuser.ambari-server.groups="users"
hadoop.proxyuser.ambari-server.hosts=ambari-server.hostname

4. Save the configuration change.

What to do next
Restart the required components as prompted by Ambari.

Set up HDFS user directory for Workflow Manager View
You must set up a directory for each user that accesses the Workflow Manager View.

About this task
Workflow Manager View stores user metadata in the user directory in HDFS. By default, the location in HDFS for
the user directory is /user/[USER_NAME], where [USER_NAME] is the user name of the currently logged in user
that is accessing Workflow Manager View.

Important:  Since many users leverage the default Ambari admin user for getting started with Ambari, you
should create a /user/admin directory if one does not exist, in addition to directories for other Workflow
Manager View users.

Procedure

1. Connect to a host in the cluster that includes the HDFS client.

2. Switch to the HDFS system account user.
su - hdfs

3. If working on a secure Kerberos cluster.

a) Destroy any existing Kerberos tickets.
kdestroy

If no ticket is found, you get an error message that you can ignore: No credentials cache file found while
destroying cache.

b) Obtain a Kerberos ticket-granting ticket.
kinit -kt /etc/security/keytabs/hdfs.headless.keytab hdfs

4. Using the HDFS client, make an HDFS directory for the user.
For example, if your username is wfmadmin, you would create the following directory: hadoop fs -mkdir /user/
wfmadmin

5. Set the ownership on the newly created directory.
For example, if your username is wfmadmin, the directory owner should be wfmadmin:hadoop.
hadoop fs -chown wfmadmin:hadoop /user/wfmadmin

6. Log in as root user.
su -

7. Access the Kerberos administration system.
kadmin.local
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8. Create a new principal and password for the user.
addprinc -pw [wfmadmin-password] wfmadmin@EXAMPLE.COM

You can use the same user name and password that you used for HDFS directory.

What to do next
Repeat steps 2 through 8 for any additional Workflow Manager View users.

Set up Kerberos for Workflow Manager View
If you install Ambari using Kerberos, the Kerberos settings for Oozie that are required for Workflow Manager are
configured automatically.

About this task
The image below shows what the settings should look like.

Procedure

1. In Ambari Web, browse to Services > Oozie > Configs > Advanced.

2. On the Advanced tab, navigate to the Advanced Oozie-site section.

3. Verify that the properties match those shown in the following figure.

Set up proxy user for Oozie
If you are using Kerberos, you must configure the proxy user for Oozie.

About this task
Workflow Manager uses Oozie as its scheduling engine.
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Procedure

1. In Ambari Web, browse to Services  > Oozie > Configs.

2. Expand the Custom oozie-site section.

3. Click Add Property…, then add the following custom properties:
oozie.service.ProxyUserService.proxyuser.[AMBARI_SERVER_CL1].groups=*

Replace [AMBARI_SERVER_CL1] with the server principal name used when configuring Kerberos.

oozie.service.ProxyUserService.proxyuser.[AMBARI_SERVER_CL1].hosts=*

Replace [AMBARI_SERVER_CL1] with the server principal name used when configuring Kerberos.

For example:

4. Save the configuration change.

What to do next
Restart the required components as prompted by Ambari.

Create and configure a Workflow Manager View instance
Use Ambari Admin to create a Workflow Manager view instance.

About this task
You can configure multiple WFM View instances. You might want to have multiples instances if you want to assign
different users and permissions for each instance. You can also have instances that run locally and others that run
remotely.

Procedure

1. Click Manage Ambari to open the Ambari Admin user interface.

2. Click Views, expand the Workflow_Manager View, and click Create Instance.

3. On the Create Instance page, select the Version.

If multiple View versions exist, choose one.

4. Enter the following view instance Details:
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Table 6: Workflow Manager View Instance Details

Property Description Example Value

Instance Name This is the Workflow Manager View
instance name and must be unique for all
instances you create. The instance name
cannot be modified after the instance is
created.

wfm_local_instance

This value cannot contain spaces or special
characters other than an underscore.

Display Name This is the name of the view link displayed
to the user in Ambari Web. The display name
can be modified after the instance is created.

WFM View

This value can contain spaces and
underscores, but no other special characters.

Description This is the description of the view displayed
to the user in Ambari Web.

Local instance of WFM

Visible This checkbox determines whether the view
is displayed to users in Ambari Web.

Visible or Not Visible

5. In Cluster Configuration, select the Local Cluster or Remote Clusterinstance type and select the cluster name.

6. Review the remaining settings and make changes as desired.

The Settings and Cluster Configuration options depend on a few cluster and deployment factors in your
environment. Typically, you can accept the default Settings unless you are using the Workflow Manager View
with a Kerberos-enabled cluster.

7. Click Save.
The instance is created and a success message displays.

8. Scroll to the Permissions section at the bottom of the Views configuration form.

9. Grant permission on the Workflow Manager View for the set of users and groups who can access the view
instance.

Related Information
Workflow Manager Guide
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https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.4.0/bk_workflow-management/content/ch_wfm_basics.html
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