Apache Ambari Installation
Also available as:
PDF
loading table of contents...

Software Requirements

On each of your hosts:

  • yum and rpm (RHEL/CentOS/Oracle/Amazon Linux)

  • zypper and php_curl (SLES)

  • apt (Debian/Ubuntu)

  • scp, curl, unzip, tar, and wget

  • OpenSSL (v1.01, build 16 or later)

  • Python

    For SLES 12:

    Python 2.7.x

    For Amazon Linux 2, CentOS 7, Ubuntu 14, Ubuntu 16, Ubuntu 18, and Debian 9:

    Python 2.7.x