Apache Ambari Operations
Also available as:
PDF
loading table of contents...

Enabling the Oozie UI

Ext JS is GPL licensed software and is no longer included in builds of HDP 2.6. Because of this, the Oozie WAR file is not built to include the Ext JS-based user interface unless Ext JS is manually installed on the Oozie server. If you add Oozie using Ambari 2.6.1.0 to an HDP 2.6.4 or greater stack, no Oozie UI will be available by default. If you want an Oozie UI, you must manually install Ext JS on the Oozie server host, then restart Oozie. During the restart operation, Ambari re-builds the Oozie WAR file and will include the Ext JS-based Oozie UI.

Steps

  1. Log in to the Oozie Server host.

  2. Download and install the Ext JS package.

    CentOS RHEL Oracle Linux 6:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/centos6/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    CentOS RHEL Oracle Linux 7:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/centos7/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    CentOS RHEL Oracle Linux 7 (PPC):

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/centos7-ppc/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    SUSE11SP3:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/suse11sp3/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    SUSE11SP4:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/suse11sp4/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    SLES12:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/sles12/extjs/extjs-2.2-1.noarch.rpm
    rpm -ivh extjs-2.2-1.noarch.rpm

    Ubuntu12:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/ubuntu12/pool/main/e/extjs/extjs_2.2-2_all.deb
    dpkg -i extjs_2.2-2_all.deb

    Ubuntu14:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/ubuntu14/pool/main/e/extjs/extjs_2.2-2_all.deb
    dpkg -i extjs_2.2-2_all.deb

    Ubuntu16:

    Wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/ubuntu16/pool/main/e/extjs/extjs_2.2-2_all.deb
    dpkg -i extjs_2.2-2_all.deb

    Debian6:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/debian6/pool/main/e/extjs/extjs_2.2-2_all.deb
    dpkg -i extjs_2.2-2_all.deb

    Debian7:

    wget http://public-repo-1.hortonworks.com/HDP-UTILS-GPL-1.1.0.22/repos/debian7/pool/main/e/extjs/extjs_2.2-2_all.deb
    dpkg -i extjs_2.2-2_all.deb
  3. Remove the following file:

    rm /usr/hdp/current/oozie-server/.prepare_war_cmd
  4. Restart Oozie Server from the Ambari UI.

    Ambari rebuilds the Oozie WAR file.