Chapter 6. Supported Database Matrix for Hortonworks Data Platform

This page contains certification information on supported databases for Hortonworks Data Platform (HDP).

The following table identifies the supported databases for HDP.

Table 6.1. Supported Databases for HDP Stack
Operating System Component Database
PostgreSQL 8.x PostgreSQL 9.x MySQL 5.x Oracle 11gr2 Other

RHEL/Centos/Oracle Linux 5.x

RHEL/CentOS/Oracle Linux 6.x

SLES 11

Ubuntu 12

Hive / HCatalog Supported. For instructions on configuring this database for Hive metastore, see Instructions for Manual Install. Supported. For instructions on configuring this database for Hive metastore, see Instructions for Manual Install . Default. For instructions on configuring this database for Hive metastore, either see Instructions for Manual Install or see Using Ambari with MySQL. Default. For instructions on configuring this database for Hive metastore, either see Instructions for Manual Install or see Using Ambari with Oracle.
Oozie Supported. For instructions on configuring this database for Oozie metastore, see Instructions for Manual Install. Supported. For instructions on configuring this database for Oozie metastore, see Instructions for Manual Install. Supported. For instructions on configuring this database for Oozie metastore, either see Instructions for Manual Install or see Using Oozie with MySQL. Supported. For instructions on configuring this database for Oozie metastore, either see Instructions for Manual Install or see Instructions for Oozie. Derby (default).
Hue [a] Supported. For instructions on configuring this database for Hue, see Instructions for Manual Install. Supported. For instructions on configuring this database for Hue, see Instructions for Manual Install . Supported. For instructions on configuring this database for Hue, see Instructions for Manual Install. Supported. For instructions on configuring this database for Hue, see Instructions for Manual Install. SQLite (default)
Ambari [b] Default. For more information, see Database Requirements. Supported. For more information, see Using Ambari with PostgreSQL. Supported. For more information, see Using Ambari with MySQL. Supported. For more information, see Using Ambari with Oracle.

[a] Hue does not currently support Ubuntu 12.

[b] Ambari does not currently support Ubuntu 12.


loading table of contents...